Jump to content
Guest

Linux & logiciels radioamateurs...

Recommended Posts

F6EEQ

Merci Sylvain

RAM: 1 Go

Espace disque LInux: 80 Go

Processeur Cellerond (1 coeur je suppose)

OK pour le forum!

Share this post


Link to post
F4HFQ

Merci Sylvain

RAM: 1 Go

Espace disque LInux: 80 Go

Processeur Cellerond (1 coeur je suppose)

OK pour le forum!

Bonjour,

Quelle version de Debian ? Stable, testing ou unstable ?

73,

Franck F4HFQ

Share this post


Link to post
F4HFQ

Je vois qu'il y a une version de CQRLog dans les dépôts Debian (version 1.4 pour les dépôts "stable", version 1.7.3 pour les dépôts "unstable"), y a-t-il une raison pour avoir téléchargé celle du site de l'éditeur ?

Quel outils avez-vous utilisé pour l'installation du .deb ?

Je pose ces questions pour essayer de reproduire le problème dans une machine virtuelle (J'utilise Xubuntu sur le pc et debian pour le serveur.).

Share this post


Link to post
Guest
../..

Processeur Cellerond (1 coeur je suppose)

../..

Je pense que vers 2007 les celeron MEROM étaient des dual-core.

73 Sylvain

Share this post


Link to post
Guest

../..

Quel outils avez-vous utilisé pour l'installation du .deb ?

Je pose ces questions pour essayer de reproduire le problème dans une machine virtuelle (J'utilise Xubuntu sur le pc et debian pour le serveur.).

Bonsoir Franck,

Je crois que le PO est en Wheezy.

Je vois que nous avons la meme démarche de se mettre dans une VM, au plus près de ses conditions.

73 Sylvain

Share this post


Link to post
Guest

Bonsoir Gérard, Franck

Voila, c'est fait:

Chargement de l'ISO netinstall de Wheezy en 32 bits.

Création d'une VM vmware avec 2 coeurs, 1 G0 de RAM et 80 G0 de HD.

Tout installé par défaut

install de CDRLOG en 1.4.1

Ca fonctionne (j'espère que vous avez fait un export de votre log).

Il m'a signalé différentes bases à mettre à jour.

73 et bonne nuit Sylvain

Share this post


Link to post
F4HFQ

Bonsoir,

Ma question sur la version de Debian Wheezy n'est pas innocente. Pour en savoir plus : http://www.debian.org/doc/manuals/debian-faq/ch-choosing.fr.html

De même pour l'installation du .deb (gestion des dépendances).

Je suppose que Gérard est sur les dépôts "stable" et ne trouve donc qu'une ancienne version de CQRLog. Il a donc certainement pris la dernière sur le site de l'éditeur mais sans gestion des dépendances.

La dernière version est dispo sur les dépôts "unstable"... et par là même toutes les dépendances utiles.

Question si mes déductions sont bonnes : volonté de rester en "stable" et donc gestion des dépendances plus compliquées ? Ou possibilité de passer en "unstable" ?

Mon opinion perso : "stable" sur serveur et "unstable" sur poste de travail.

Suis dispo pour faire des tests en machine virtuelle au besoin et suivant les réponses.

73,

Franck F4HFQ

PS : message rédigé sur smartphone... j'espère sans trop de coquilles.

Share this post


Link to post
F6EEQ

Merci de vos réponses et du temps passé.

J'ai essayé (sur le conseil d'un OM Italien dans le forum CQRlog) de charger la version "unstable", mais ça ne marche pas.

Maintenant je n'ai peut-être pas fait la manip comme il faut. Je n'ai pas tout compris et la doc DEBIAN n'est pas claire à ce sujet.

Instable signifie DEBIAN et les paquets associés ou seulement les paquets?

Quand j'ai chargé CQR en local je pensais avoir toutes les dépendances avec, ou tout du moins les liens qui permettent à APT ou autre chargeur de les retrouver.

Pour répondre à une autre question, je suis bien en WHEEZY avec les DVD achetés à GETLINUX car ma liaison ADSL est pourrie et il m'est quasiment impossible de charger un DVD entier.

Habiter à la campagne ça a des avantages pour les antennes, mais en ce qui concerne le téléphone/ADSL il vaut mieux être en ville!!!

Share this post


Link to post
Guest

Merci de vos réponses et du temps passé.

../..

Habiter à la campagne ça a des avantages pour les antennes, mais en ce qui concerne le téléphone/ADSL il vaut mieux être en ville!!!

On ne va pas épiloguer (polémiquer ?) sur les nombreux avantages de la campagne (prix du terrain, de la construction, espace, air pur, bouchons, qualité de la vie, beurre, fermière ...) mais il est évident qu'une bonne liaison Internet est un plus en informatique.

Comme indiqué, j'ai installé ma VM avec l'ISO netinstall ce qui fait que tout est parfaitement à jour. Pour ce test, je n'ai même pas modifié le sources.list

(ni nonfree, ni backports).

Après une recherche sur Internet, j'ai téléchargé le package debian de CQRLOG et, comme j'étais connecté, les dépendances ont été résolues automatiquement.

Avez-vous la possibilité de descendre "à la ville" (travail, famille, ami, radio club...) avec votre ordinateur afin de disposer d'une connexion temporaire de bonne qualité ?

Nota: En restant sur le forum vous avez gagné un second intervenant et comme dit l'adage, il y en a plus dans 2 têtes .....

73 Sylvain

Edited by Guest

Share this post


Link to post
F6EEQ

Le PC est un PC de bureau, donc pas facile à déplacer.

Ceci dit le paquet CQRlog n'est pas très gros.

J'ai bien téléchargé le dernier paquet disponible sur le site de CQR (CQRxxxx.DEB) mais à l'installation j'ai un message comme quoi HAMLIB n'est pas à la bonne version...

Là je suis au boulot, donc je ne peux pas faire grand chose, j'essayerai encore ce soir.

Share this post


Link to post
F4HFQ

Merci de vos réponses et du temps passé.

J'ai essayé (sur le conseil d'un OM Italien dans le forum CQRlog) de charger la version "unstable", mais ça ne marche pas.

Maintenant je n'ai peut-être pas fait la manip comme il faut. Je n'ai pas tout compris et la doc DEBIAN n'est pas claire à ce sujet.

Instable signifie DEBIAN et les paquets associés ou seulement les paquets?

Quand j'ai chargé CQR en local je pensais avoir toutes les dépendances avec, ou tout du moins les liens qui permettent à APT ou autre chargeur de les retrouver.

Pour répondre à une autre question, je suis bien en WHEEZY avec les DVD achetés à GETLINUX car ma liaison ADSL est pourrie et il m'est quasiment impossible de charger un DVD entier.

Habiter à la campagne ça a des avantages pour les antennes, mais en ce qui concerne le téléphone/ADSL il vaut mieux être en ville!!!

Bonjour,

J'ai lu votre fil de discussion sur le forum de CQRLog. D'après ce que j'ai compris, vous aviez ajouté le dépôt qu'ils annoncent sur leur site. C'est une erreur : si les paquets fournis dans ce dépôt sont bien des .deb, le dépôt n'est pas prévu pour debian, mais pour Ubuntu (qui est bien un dérivé de debian). Vous devriez supprimer ce dépôt de vos sources et désinstaller la version de CQRLog présente dans votre système.

Ensuite, plusieurs solutions :

1. vous souhaitez rester sur la version "stable" de debian

1.1 vous vous contentez de la version de CQRLog disponible dans les dépôts "stable" -> 1.4.1

1.2 vous souhaitez installer la dernière version de CQRLog -> suivez cette partie des conseils de l'om italien :

However, the latest current version of package cqrlog is on the author's site: "http://www.cqrlog.com/files/cqrlog_1.7.3/cqrlog_1.7.3-1_i386.deb."

try to install it from the terminal with gdebi, for example:

sudo gdebi cqrlog_1.7.3-1_i386.deb

2. vous souhaitez avoir la dernière version de vos logiciels préférés, de façon transparente : passez à "unstable" -> pour répondre à votre question sur le sujet : tout le système passera en "unstable". En temps normal, c'est ce que je conseillerai pour un PC perso. Il semble cependant que votre connexion internet soit quelque peu limité, or il y aura énormément de mises à jour à télécharger.

Je ne suis pas chez moi et ne peux donc pas faire la manip 1.2 dans la machine virtuelle pour vous fournir un guide pas à pas détaillé. Si vous le souhaitez, je pourrai faire ça ce soir (ou cette nuit).

73,

Franck F4HFQ

Share this post


Link to post
F6EEQ

Merci Frank,

si je me souviens bien, j'ai essayé ce qui est dit en 1.2 et ça ne marchait pas. Je ne me souviens pas si c'était que Gdebi ne trouvait pas le paquet ou si c'était l'erreur sur hamlib. Je crois que c'était le 2° cas, mais sans garantie!!

On ne peut pas faire ça sans être devant le PC ;) !!

Share this post


Link to post
Guest

Le PC est un PC de bureau, donc pas facile à déplacer.

../..

J'ai bien téléchargé le dernier paquet disponible sur le site de CQR (CQRxxxx.DEB) mais à l'installation j'ai un message comme quoi HAMLIB n'est pas à la bonne version...

Pas besoin d'emporter tout, juste l'UC. Le reste, clavier/écran/souris, ça se trouve sur place.

Bon je vais désinstaller mon 1.4 et tester celui du site de CQRLOG. Gros avantage de la VM, on ne risque rien .

73 Sylvain

Share this post


Link to post
Guest

Voila, c'est fait et ça fonctionne.

Comme l'a souligné Franck , Debian c'est Debian. Même si Ubuntu ou koppix en sont dérivées, il ne faut pas mélanger les dépôts.

Comme déjà indiqué, ma VM Debian est vierge de toute installation et le sources.list est celui d'origine.

Je crains que votre problème subsistera tant que vous ne pourrez pas faire une mise à jour en ligne.

Bon courage.

73 Sylvain

PS) Je poste depuis ma VM.

Edited by Guest

Share this post


Link to post
F6EEQ

Voici ce que j'obtiens si j'essaye d''installer.

root@Schack:/home/f6eeq# aptitude install cqrlog
Impossible de trouver un paquet dont le nom ou la description corresponde à « cqrlog »
Impossible de trouver un paquet dont le nom ou la description corresponde à « cqrlog »
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 10 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.

Je suppose que le dépôt DEBIAN "Stable" est connu et qu'on n'a pas besoin de le définir??

Share this post


Link to post
F4HFQ

Gérard,

Je viens de faire le test dans la machine virtuelle. Pour rappel, Debian a été installé dans cette machine virtuelle de façon tout à fait standard, avec les options par défaut, en 32bit.
J'ai ensuite téléchargé le .deb depuis le lien de mon post #236. J'ai choisi de faire l'installation en mode fenêtré au lieu de passer par la ligne de commande (ce sera plus explicite pour vous et certainement plus près de ce que vous attendez).
Vous trouverez ci-jointes les captures d'écran faites lors de l'installation : une image vaut mieux qu'un long discours. Vous verrez notamment que le système vous prévient qu'il dispose d'une version plus antérieure à celle que l'on souhaite utiliser dans ses dépôts. C'est juste informatif.
Autre chose à noter : 18 paquets supplémentaires à installer pour satisfaire les dépendances. C'est le logiciel d'installation qui le dit.
A la fin de l'installation, il est possible de lancer CQRLog... sans message d'erreur.

Avant de lancer cette installation, je vous recommande :
1. de nettoyer le système de votre précédente installation de CQRLog
2. de supprimer le dépôt que vous aviez ajouté par erreur

73,

Franck F4HFQ

debian-CQRLog.zip

Share this post


Link to post
F4HFQ

Voici ce que j'obtiens si j'essaye d''installer.

root@Schack:/home/f6eeq# aptitude install cqrlog

Impossible de trouver un paquet dont le nom ou la description corresponde à « cqrlog »

Impossible de trouver un paquet dont le nom ou la description corresponde à « cqrlog »

Aucun paquet ne va être installé, mis à jour ou enlevé.

0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 10 non mis à jour.

Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.

Je suppose que le dépôt DEBIAN "Stable" est connu et qu'on n'a pas besoin de le définir??

Je connais mal aptitude en ligne de commande. J'utilise plutôt apt-get.

Je viens de faire le test dans la VM. Résultat, en utilisant aptitude : même réponse que vous. En utilisant apt-get, un message me signale que j'ai une version plus récente que celle des dépôts (normal, cf mon précédent post :) )

73,

Franck F4HFQ

Share this post


Link to post
Guest

Bonsoir,

On arrive donc bien à installer la dernière version disponible sur le site ce CQRLOG. Avec un sources.list standard et une bonne connexion Internet, le gestionnaire de paquets fait son travail et charge les paquets manquants pour résoudre les dépendances.

Une fois le paquet téléchargé depuis le site, il m'a suffit de lancer le gestionnaire de fichiers sur le répertoire de téléchargement. Un clic droit sur le fichier et choisir "ouvrir avec installation de logiciels".

Il est probable qu'avec l'installation à partir d'un DVD, toutes les bibliothèques ou logiciels nécessaires n'ont pas été installés par défaut et que (ou que) certains ne soient pas à la bonne version.

Comme de plus, sauf erreur de ma part, le support d'installation est commenté dans le fichier sources.list (à vérifier sur /etc/apt/sources.list ), je crains que notre ami doive envisager ma proposition de se rendre "à la ville" avec son UC.

73 Sylvain

Share this post


Link to post
F6EEQ

Bof, on lancera le téléchargement le matin et on verra le résultat le soir :lol: :lol:

Merci de vos infos. J'avais cru que APTITUDE était + robuste que APT, c'est du moins ce que j'avais compris de la doc DEBIAN en ligne.

Une autre info de béotien: j'ai bien compris qu'il peut (et qu'il doit!) y avoir une incompatibilité de versions, mais comment "updater" mon système?

J'ai fait hier un APTITUDE UPDATE et il y a plein de chose qui n'ont soit pas été installées, soit parties en erreur, soit pas trouvées??

En tous cas merci pour votre aide. Je trouve que le forum DEBIAN est bien qand on sait déjà à peu près ce qu'on fait, mais pour des débutants c'est pas terrible.

De plus la doc DEBIAN est assez hermétique. Par exemple j'ai merdé pas mal de temps pour trouver comment vérifier si ma liaison série fonctionnait. Maintenant je sais qu'elle est installée, mais il faudra vérifier si elle fonctionne... quand j'aurai CQR!!!

Bonne journée et @+

Share this post


Link to post
Guest

Bof, on lancera le téléchargement le matin et on verra le résultat le soir :lol: :lol:

En tous cas merci pour votre aide. Je trouve que le forum DEBIAN est bien qand on sait déjà à peu près ce qu'on fait, mais pour des débutants c'est pas terrible.

Bon c'est vrai que votre ligne n'est pas terrible (5221 m et et 65 dB d'atténuation) degrouptest estime le débit max vers 1.9 Mbps mais pour cela, il ne faut pas être chez l'agrume qui limitera à 512 K. ceci dit, même 512 K c'est suffisant pour gérer un linux et mettre à jour. cela demande juste un peu plus de temps. Maintenant, si vous avez de nombreuses déconnexions, c'est plus problématique.

Pour le forum Debian, pour donner un aperçu aux lecteurs qui ne le fréquentent pas, c'est comme si radioamateur.org n'avait qu'une seule rubrique. Il est très difficile d'y retrouver ses petits et un topic chasse rapidement l'autre (et cela n’évoluera pas car c'est comme ça depuis 10 ans).

73 Sylvain

Share this post


Link to post
F6EEQ

J'ai découvert aujourd'hui DEBIAN Facile qui m'a l'air plus réactif et plus adapté.

Comment avez-vous trouvé les caractéristiques de ma ligne?? C'est vrai qu'il y a mes coordonnées dans mon profil!!

Share this post


Link to post
Guest
../..

Comment avez-vous trouvé les caractéristiques de ma ligne?? C'est vrai qu'il y a mes coordonnées dans mon profil!!

Dans la mesure où ni vous, ni moi, ne sommes paranoïaques, il est assez facile de trouver ces renseignements sans attenter à la vie privée:

1) ANFR, annuaire des radioamateurs:

à partir de l'indicatif, on obtient nom, prénom, adresse.

2) annuaire pages blanches:

à partir de nom, adresse on obtient numéro de téléphone.

3) Degrouptest:

à partir de n° téléphone + code postal on obtient NRA, longueur ligne, atténuation, débit estimé, offres des opérateurs.

CQFD.

73 Sylvain

Share this post


Link to post
F8DQL

Comment avez-vous trouvé les caractéristiques de ma ligne?? C'est vrai qu'il y a mes coordonnées dans mon profil!!

Les coordonnées dans votre profil ne sont en aucun cas accessibles par les utilisateurs.

Share this post


Link to post
F6EEQ

Bien, ça m'aura évité de le faire, et ça me conforte dans mon idée de réclamer une amélioration à Orange!!!

Mon voisin qui est infographiste s'arrache les cheveux pour lire/envoyer de gros fichiers! Et dire qu'on veut faire la promotion du numérique à tout va!!! Mais ceci est une autre histoire et pas le sujet du forum.

Share this post


Link to post
F6EEQ

OK Jean-Baptiste!!!

Pour Sylvain: je vais ré-essayer ce soir avec APT et je vous tiens au courant, mais sans vouloir être exigeant (!!) je n'ai pas eu de réponse à ma question sur l'update du système/paquets.

Merci d'avance.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...