Jump to content
F6CTW

IC-7300 date et heure, mise à jour firmware

Recommended Posts

F6CTW

Bonjour à tous,
Comme indiqué dans le titre je rencontre 2 problèmes avec mon IC-7300:

1. Sauvegarde date et heure:
a) si j'arrête le TX (power off) et l'alim 12V puis remet tout en route immédiatement ou peu de temps après: pas de problème.
b) mais quand je reviens le lendemain, on repart du 01/01/2000 à 0:00.
A noter que "UTC Offset" reste bien sauvegardé ainsi que mémoires, limites de bandes etc...
J'ai essayé "Partial Reset" et "All Reset" sans succès.
J'ai voulu essayer la mise à jour du firmware et c'est là que commence le deuxième problème:

2. Mise à jour du firmware:
a) J'ai suivi la procédure (notice p 15-3): téléchargement et décompression du fichier sur une carte SD, répertoire "IC-7300" de la version 1.30.
b) Mais quand j'essaye la mise à  jour (notice p 15-5) après l'écran d'avertissement jaune, j'ai l'indication "No File".
A noter que je suis déjà en version 1.30: est-ce cela la raison? On ne peut pas "ré-écrire" une m-à-j pour corriger un problème?

Essais effectués avec 2 cartes SD différentes et qui sont OK: sauvegarde settings, enregistrements QSO...

Merci d'avance pour toute info.

René
F6CTW

Share this post


Link to post
BEZOMBES Jean-Louis

Bonjour,

Ca doit être un probléme de la pile ( ou condensateur) de l'horloge, qui ne fonctionne plus après mise off de l'appareil.

Les paramétres eux sont sauvegardés dans une mémoire flash.

 

Jean-Louis

Share this post


Link to post
F6CTW

Bonjour Jean-Louis,

Merci pour la réponse.

Il n'y a pas de pile lithium dans ce TX.

Je vais rechercher sur le schéma un éventuel condo/pile qui sera de toutes façon difficile à  remplacer...

Bonne journée.

René
F6CTW

Share this post


Link to post
BEZOMBES Jean-Louis

Il doit bien y avoir une horloge temps reel pas bien loin ( sur le schema) du processeur qui gére l'environnement graphique, face avant....

 

Jean-Louis

Share this post


Link to post
F6CTW

Effectivement, Jean-Louis, il y a bien une batterie lithium rechargeable de 3V près du processeur.

Comme elle n'est pas sensée être changée, il n'en est pas fait mention dans la notice, seulement dans le service manual sur la photo de la main board: back battery (for  the real time clock) et sur  le schéma (BT381).

Au bout de quelques minutes après mise off, elle redescend à 2.4V.

Je vais voir avec ICOM France dès lundi pour une pile neuve.

Merci de m'avoir aiguillé vers la solution.

Il me reste encore le problème n°2 concernant la mise à jour du firmware.

Bonne soirée.

René
F6CTW

  • Message intéressant 1

Share this post


Link to post
F6CTW

Pour les om's que cela intéresse, il y a également une batterie lithium rechargeable de 3V sur le 9700 (même schéma).

René
F6CTW

Share this post


Link to post
F4IEV

Bonjour. Avez-vous trouvé une solution pour cette pile ? Se change t-elle facilement ? J'ai le même symptôme. Merci.

Share this post


Link to post
F8BHA
Le 21/02/2020 à 19:30, F6CTW a dit :

Pour les om's que cela intéresse, il y a également une batterie lithium rechargeable de 3V sur le 9700 (même schéma).

René
F6CTW

bonsoir , desolé du retard , le changer contre une CR2032 

http://www.g4izh.co.uk/clock-back-up-battery-replacement.html

Share this post


Link to post
F5LOL
Le 21/02/2020 à 12:35, F6CTW a dit :

mais quand je reviens le lendemain, on repart du 01/01/2000 à 0:00.

Bonjour,

La pile de l'IC 7300 se recharge très lentement quand l'appareil est sous tension, même éteint. il faut plusieurs jours pours la charger complètement. L'heure ne reste en mémoire que si la pile est chargée. Donc si on coupe l'alimentation alors que la pile n'est pas assez chargée, l' heure revient à 0 à l'allumage suivant. Quand la pile est bien rechargée, l'heure peut rester en mémoire plusieurs jours même alimentation coupée. La pile ne concerne que l'heure pas la RAM où les réglages sont mémorisés. Il n' y a aucune solution à ce problème sauf à laisser l'appareil sous tension, la consommation étant infime.

Si le firmware est déjà en version 1.30, à mon avis il n'y a pas lieu de le recharger.

73 Jean-Pierre F5LOL

 

Share this post


Link to post
F6CTW
Il y a 6 heures, F4IEV a dit :

Bonjour. Avez-vous trouvé une solution pour cette pile ? Se change t-elle facilement ? J'ai le même symptôme. Merci.

Bonsoir,

Cela se fait, je ne dirait pas facilement (la pile est minuscule et difficile à dessouder), mais on y arrive.

La prochaine fois, je m'orienterai plutôt vers la solution de G4IZH: CR2032 sur support + 1N4001 (post de F8BHA).

73

René

F6CTW

Share this post


Link to post
F5LOL
Il y a 9 heures, F6CTW a dit :

La prochaine fois, je m'orienterai plutôt vers la solution de G4IZH: CR2032 sur support + 1N4001 (post de F8BHA).

Pour info: la pile du 7300 a une capacité de 1mAh; le circuit d'horloge consomme entre 0.8 et 1µA. En théorie la pile est capable d'alimenter le circuit d'horloge durant 1000H soit 41 jours.

La pile est chargée sous 3.3V à travers une diode et une résistance de 3.3KΩ. Le courant de charge est d'environ 10µA  puis diminue quand la batterie est chargée. On peut estimer le temps de charge à 100heures soit au minimum 4 jours sous tension poste éteint ou allumé.

Il est possible de remplacer la pile par un super condensateur de 0.5 Farad par exemple et d'augmenter le courant de charge; il existe aussi la solution élégante d'alimenter l'horloge par le super condensateur de la RAM (C243) avec une diode entre C243 et cathode de D381. Dans ces 2 cas, cela nécessite une modification très minutieuse du circuit  imprimé. Si on ne veut pas s'aventurer dans des modifications plus ou moins bien réalisées impactant la valeur du poste, il vaut mieux à mon avis laisser le poste d'origine et attendre patiemment la charge complète da la batterie quitte à laisser  le poste sous tension. quand il n'est pas utilisé.

73 F5LOL Jean-Pierre

  • Message intéressant 2

Share this post


Link to post
F4IEV

Merci pour la clarté et la qualité des réponses.

Cordiales 73.

F4IEV Jean-Marie

Share this post


Link to post
F5LOL
il y a 13 minutes, F4IEV a dit :

Merci pour la clarté et la qualité des réponses

Bonsoir Jean-Marie, merci pour votre commentaire, ça fait toujours plaisir. Par contre oubliez l'idée de la diode entre C243 et D381, j'ai vérifié, C243 ne conserve pas la charge une fois le poste débranché. 

73 QRO Jean-Pierre F5LOL

Share this post


Link to post
F4IEV

Bonjour à tous. De mon coté, j'ai bien suivi les précieux conseils de Jean-Pierre F5LOL, rien à faire... J'ai laissé le transceiver sous tension le temps d'un week-end en permanence. La pile ne tiens toujours pas la charge. Cela peut paraitre un détail, mais sur un appareil de cette gamme ça fait désordre. Je vais voir du coté de chez Icom France. 

73 QRO.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...